KeyNotFoundException with latest version

Apr 26, 2012 at 1:47 PM


I have been trying to import data from this fan page -

No matter what Attribute I select and irrespective of the 'Network' and 'Options', I get the below error. How do I work around this?



[KeyNotFoundException]: The given key was not present in the dictionary.
   at System.ThrowHelper.ThrowKeyNotFoundException()
   at System.Collections.Generic.Dictionary`2.get_Item(TKey key)
   at Smrf.NodeXL.GraphDataProviders.Facebook.FacebookFanPageNetworkAnalyzer.DownloadLikes(FacebookAPI fb, JSONObject streamPosts)
   at Smrf.NodeXL.GraphDataProviders.Facebook.FacebookFanPageNetworkAnalyzer.GetFanPageNetworkInternal(String sAccessToken, String fanPageUsernameID, List`1 netTypes, Int32 nrOfFirstPosts, Dictionary`2 attributes, Boolean getStatusUpdates, Boolean getWallPosts, Boolean includeOthers, DateTime untilDate)
   at Smrf.NodeXL.GraphDataProviders.Facebook.FacebookFanPageNetworkAnalyzer.BackgroundWorker_DoWork(Object sender, DoWorkEventArgs e)
   at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
   at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

Apr 27, 2012 at 4:00 PM


Can you please check if you are using the latest version available (1.4)? If so, can you specify the options you used so I can regenerate the error and see where is the problem. I tested the network importer with the mentioned page for the last 3 posts and it downloaded the network successfully.




May 9, 2012 at 2:41 AM

I am running v1.4 and I also get this error. See my screenshot of options here:!1778&parid=9C2531F3EF13D6B4!1777&authkey=!ANWWS2KLvK3X1Mg


When I lowered to "last 3 posts" I got an "[IndexOutOfRangeException]: Index was outside the bounds of the array." But anything above 3 throws the KeyNotFoundException.

Jun 24, 2012 at 3:20 PM

Hello wangela,


sorry for the late reply. I was able to reproduce your error and fixed it. Can you please try the new 1.5 alpha version? You can download it from here




Aug 1, 2012 at 2:53 PM



I tried the new 1.5 alpha version, but still encountered problems. Specifically, the error message says that This API could not be complete due to resource limites.


I am trying to import data from my personal network. I have nearly 700 hundred friends on Facebook. The only attribute I opted to import is friends' name. What can be some possible solution to this error?  


Here is the link to the screenshot of the error. Thank you very much.