Issue importing fan page network (1.6.1)

Nov 13, 2012 at 1:06 PM

I'm trying to import a fan page network using v1.6.1. The page name is "maquiagemnatura", only "name" as attribute, only "based on co-likes" enabled and "download 2 most recent posts":

https://www.dropbox.com/s/7xqz98c7vvqzsa0/nodexl.PNG

The error thrown is shown below. 

Another thing is that, although I downloaded and updated the DLL files for 1.6.1, it still shows as 1.6 at the menu and title bar of the window. 

Ideas?

Thanks.

Ricardo

 

---------------------------SocialNetImporter---------------------------

The network couldn't be obtained. If the problem persists please copy the following message and report it to http://socialnetimporter.codeplex.com/discussions. 


 Details:


[FacebookAPIException]: https://graph.facebook.com/198805403574488-The remote server returned an error: (400) Bad Request.
   at Facebook.FacebookAPI.MakeRequest(Uri url, HttpVerb httpVerb, Dictionary`2 args)
   at Facebook.FacebookAPI.Call(String relativePath, HttpVerb httpVerb, Dictionary`2 args)
   at Facebook.FacebookAPI.Get(String relativePath)
   at Smrf.NodeXL.GraphDataProviders.Facebook.FacebookFanPageNetworkAnalyzer.AddLikerVertices(GraphMLXmlDocument& oGraphMLXmlDocument, Dictionary`2 likersPost, Dictionary`2 attributeValues, Boolean getStatusUpdates, Boolean getWallPosts, Dictionary`2 statusUpdates, Dictionary`2 wallPosts) in C:\Users\arber.ceni\Dropbox\SocialNetImporter\SocialNetImporter\SocialNetImporter\NetworkAnalyzers\Facebook\FacebookFanPageNetworkAnalyzer.cs:line 790
   at Smrf.NodeXL.GraphDataProviders.Facebook.FacebookFanPageNetworkAnalyzer.AddVertices(GraphMLXmlDocument& oGraphMLXmlDocument, Dictionary`2& attributeValues, FacebookAPI fb, Dictionary`2 attributes, Boolean getStatusUpdates, Boolean getWallPosts, List`1 netTypes, Dictionary`2 commentersComments, Dictionary`2 likersPosts, JSONObject streamPosts) in C:\Users\arber.ceni\Dropbox\SocialNetImporter\SocialNetImporter\SocialNetImporter\NetworkAnalyzers\Facebook\FacebookFanPageNetworkAnalyzer.cs:line 657
   at Smrf.NodeXL.GraphDataProviders.Facebook.FacebookFanPageNetworkAnalyzer.GetFanPageNetworkInternal(String sAccessToken, String fanPageUsernameID, List`1 netTypes, Int32 nrOfFirstPosts, Dictionary`2 attributes, Boolean getStatusUpdates, Boolean getWallPosts, Boolean includeOthers, DateTime startDate, DateTime endDate) in C:\Users\arber.ceni\Dropbox\SocialNetImporter\SocialNetImporter\SocialNetImporter\NetworkAnalyzers\Facebook\FacebookFanPageNetworkAnalyzer.cs:line 299
   at Smrf.NodeXL.GraphDataProviders.Facebook.FacebookFanPageNetworkAnalyzer.BackgroundWorker_DoWork(Object sender, DoWorkEventArgs e) in C:\Users\arber.ceni\Dropbox\SocialNetImporter\SocialNetImporter\SocialNetImporter\NetworkAnalyzers\Facebook\FacebookFanPageNetworkAnalyzer.cs:line 2120
   at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)---------------------------OK   ---------------------------

Coordinator
Nov 13, 2012 at 1:22 PM

Hello Ricardo,

thank you for reporting your issue. It seems like you haven't replaced FacebookAPI.dll file. Please replace the file and try again.

About the version: it is a typo :). We will update the version immediately.

 

Thanks again.

Arber

Nov 13, 2012 at 1:25 PM

Actually, I did replace FacebookAPI.dll. I replaced all DLLs. Because it is showing 1.6, I fully deleted everything before copying the new files, just to be sure. 

Can you reproduce the error using 1.6.1?

Ricardo

Coordinator
Nov 13, 2012 at 1:33 PM

Hello Ricardo,

no I was not able to reproduce the error. I actually succeeded in downloading the network, but it fails when importing it in NodeXL (I get a System.OutOfMemory Exception which means that the network is too large).

I will check again and be back as soon as possible.

 

Regards,

Arber

Nov 13, 2012 at 1:36 PM

That's strange. I'll wait for an updated version that shows 1.6.1 properly, so that I know for sure I'm using the latest version. :)

Thanks.

Ricardo

Coordinator
Nov 13, 2012 at 1:46 PM

Hello Ricardo,

I just replaced the release. Can you please download and retry?

 

Regards,

Arber

Nov 13, 2012 at 3:03 PM

Just did. It now shows 1.6.1 and there's an additional file in the package (FacebookAPI.pdb). But I'm still seeing the exact same error message :(

Ricardo

Coordinator
Nov 13, 2012 at 3:27 PM

I changed something that might be the problem and uploaded again. Can you please retry?

 

Thanks,

Arber

Nov 19, 2012 at 9:23 PM

Arber,

Worked like a charm. :D

Thank you so much!

Ricardo